Commit e4523668 authored by acoburn's avatar acoburn
Browse files

Merge branch 'update_camel_toolbox' into 'master'

Update custom LDPath extension to use fcrepo-camel-toolbox/4.7.1

See merge request !87
parents d10c48f7 1485ff8d
......@@ -48,6 +48,7 @@ jar {
org.apache.marmotta.ldclient.endpoint.rdf,
org.apache.marmotta.ldclient.provider.rdf,
org.apache.marmotta.ldpath.backend.linkeddata,
org.fcrepo.client,
org.fcrepo.camel.ldpath,
${defaultOsgiImports}"""
instruction 'Export-Package', "edu.amherst.acdc.exts.ldpath;version=${projectOsgiVersion}"
......
......@@ -37,17 +37,21 @@
<argument index="1" type="int" value="${fcrepo.authPort}"/>
</bean>
<bean id="fedoraEndpoint" class="org.fcrepo.camel.ldpath.FedoraEndpoint">
<argument index="0" type="java.lang.String" value="${fcrepo.baseUrl}"/>
<argument index="1" type="java.lang.Long" value="${fcrepo.cache.timeout}"/>
<bean id="fcrepoHttpClientBuilder" class="org.fcrepo.client.FcrepoHttpClientBuilder">
<argument index="0" type="java.lang.String" value="${fcrepo.authUsername}"/>
<argument index="1" type="java.lang.String" value="${fcrepo.authPassword}"/>
<argument index="2" type="java.lang.String" value="${fcrepo.authHostname}"/>
</bean>
<bean id="client" class="org.fcrepo.camel.ldpath.ClientFactory" factory-method="createClient">
<argument ref="authScope"/>
<argument ref="credentials"/>
<argument ref="fedoraEndpoint"/>
<argument>
<list>
<bean class="org.fcrepo.camel.ldpath.FedoraEndpoint">
<argument index="0" type="java.lang.String" value="${fcrepo.baseUrl}"/>
<argument index="1" type="java.lang.Long" value="${fcrepo.cache.timeout}"/>
</bean>
<bean class="edu.amherst.acdc.exts.ldpath.GettyEndpoint">
<argument type="java.lang.Long" value="${cache.timeout}"/>
</bean>
......@@ -55,6 +59,9 @@
</argument>
<argument>
<list>
<bean class="org.fcrepo.camel.ldpath.FedoraProvider">
<argument ref="fcrepoHttpClientBuilder"/>
</bean>
<bean class="edu.amherst.acdc.exts.ldpath.GettyProvider"/>
</list>
</argument>
......
......@@ -66,6 +66,11 @@
<feature version="${fcrepoCamelToolboxVersionRange}">fcrepo-ldpath-core</feature>
<feature version="${fcrepoCamelToolboxVersionRange}">fcrepo-service-ldcache-file</feature>
<bundle dependency="true">mvn:org.fcrepo.client/fcrepo-java-client/${fcrepoClientVersion}</bundle>
<bundle dependency="true">mvn:org.apache.commons/commons-lang3/${commonsLangVersion}</bundle>
<bundle dependency="true">mvn:org.apache.httpcomponents/httpclient-osgi/${httpclientVersion}</bundle>
<bundle dependency="true">mvn:org.apache.httpcomponents/httpcore-osgi/${httpcoreVersion}</bundle>
<bundle>mvn:edu.amherst.acdc/acrepo-exts-ldpath/${project.version}</bundle>
<configfile finalname="/etc/edu.amherst.acdc.exts.ldpath.cfg">mvn:edu.amherst.acdc/acrepo-exts-ldpath/${project.version}/cfg/configuration</configfile>
......
......@@ -47,7 +47,7 @@ subprojects {
camelVersionRange = '[2.18,3)'
activemqVersionRange = '[5.14,6)'
fcrepoCamelVersionRange = '[4.5,5)'
fcrepoCamelToolboxVersionRange = '[4.7,5)'
fcrepoCamelToolboxVersionRange = '[4.7.1,5)'
/* Dependencies */
activemqVersion = '5.14.1'
......@@ -56,7 +56,7 @@ subprojects {
commonsLangVersion = '3.4'
derbyVersion = '10.12.1.1'
fcrepoCamelVersion = '4.5.0'
fcrepoCamelToolboxVersion = '4.7.0'
fcrepoCamelToolboxVersion = '4.7.1'
hk2Version = '2.4.0'
httpclientVersion = '4.5.2'
httpcoreVersion = '4.4.5'
......@@ -84,6 +84,7 @@ subprojects {
commonsValidatorVersion = '1.4.0'
dexxVersion = '0.6'
fluentHcVersion = '4.5.2'
fcrepoClientVersion = '0.2.1'
httpclientCacheVersion = '4.3.5'
httpmimeVersion = '4.5.2'
httpcoreNioVersion = '4.4.4'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment